StoryMap Training: Map Tour @esri

Exercise: Story Map Tour

CCIM Chapter Training Webinars | August/September 2016

In this tutorial you will create a Story Map Tour.

You’ll have about 30 minutes for this exercise.
FEEL FREE TO USE YOUR OWN CONTENT INSTEAD OF WHAT WE SHOW HERE.

Launch the Story Map Tour Builder

Go to http://storymaps.arcgis.com

1. At the top of the page, click Apps.

2. Find Story Map Tour in the list of apps
and click Build.

3. Sign in to your ArcGIS account, if
prompted.

CREATE STORY |

Alternatively, you can click 'Learn More' to go
to the Story Map Tour page:
http://storymaps.arcgis.com/en/app-list/map-tour/
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Build your Map Tour — Point to your Photos

Welcome to the Map Tour Builder » ST

Where are your images or videos?

Enter your Flickr user name and select a Photo Set or a Tag to be
imported. Your pictures must be shared publicly. The import will be
limited to the first 99 pictures.

Rupert Essinger o l Look up 9

ey are already online | need to upload my images

Select a Photo Set or Select a Tag

] A Winter Hike in Mammoth (2 v Please Choose

B © -

O

You

Learn more

1. Enter “Rupert Essinger" (or use your own
account if you already have pictures in Flickr)

The Map Tour Builder supports several popular 2. Click Look up.

photo services, or you can upload your photos.
3. Select the “A Winter Hike in Mammoth”

For this Map Tour, you’ll use photos on Flickr: photo set (Flickr aloum).

1. Click Flickr. 4. Click Import
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Build your Story Map Tour — Locate Your Tour Points

SEiect and locate yourimagesnideos These photos were taken with a GPS-enabled camera (e.g., an
Click or tap the pictures you want to import to locate them. Why aren't IPhone)’ Y they have Iocatlon Informatlon already’ WhICh the
e \ Story Map Tour will use automatically. If any of the pictures

To locate (0) Located (24)

did not have locations stored with them, this dialog will let
you locate them before importing them.

Press Import.

The photos appear in your tour. In Flickr, these photos were
given names and captions, so that text is automatically used
in your tour. The order in which the photos were added into
Flickr (or their current order in the album if they were
reordered manually in Flickr) is also reflected automatically in
the order in which they appear in your tour.

You can now edit the tour point names, captions, locations and change the order now if you want.

There are several things you can choose to do next (in any order).

© Esri 2016 Page 3



StoryMap Training: Map Tour

A Winter Hike in Mammoth STORY Ct

it mel when you are done
it

1 unsaved cha

Change media Change thumbnail 3

%
)

Welcome to Mammoth This tour shows you an easy 6 mile round-trip day hike into
< the Eastern Sierra high country. Total elevation gain is only
Lakes, Californial 833 feet. In winter you'll need snowshoes and poles. Rent
them in town or bring your own.

& esri

Astoymap B3 W &

&= agri

» Change Basemap
|

1. Add your own logo into the header to give your map tour your own branding. Click Settings and
choose the Header tab. In the Story Map Tour the logo graphic is referenced via a URL and can be a
png or jpg file (max size is 250 pixels by 50 pixels). Here's a made-up logo graphic we created that

you can use:

http://downloads.esri.com/blogs/places/training/logo.png

© Esri 2016

(filename is logo.png)

Page 4


http://downloads.esri.com/blogs/places/training/logo.png

StoryMap Training: Map Tour

Story settings
When you specify your own custom logo graphic, you Layout | Colors | Header | Data | Extent | Zoom Level
should also specify a click-through URL link. That's the Customize the header logo (maximum is 250 x 50px).

URL that your readers will be taken to if they click on Esrilogo

No logo

your logo, e.g. the URL of your company’s home page. o CUstom ogo

m/blogs/places/training/logo.png

Click-through link

2. Change the color scheme used in your tour, such as

Customize the header top right link.

the header color. Click Settings and choose the Colors 2 Facebook

Text: | A story map

w Twitter

tab. For example, you could match the corporate identity Link: | nipstorymaps arcgiscom 2 sy
color scheme used by your organization.

Apply Cancel

3. Use the Organize button if you want to make the first
picture be an intro picture, which won't be shown on your
map as a point. It's a cool way to set the scene with a great
image and introductory text, without that image and text
being linked to a point on your map. Check the box at the
bottom of the Organize dialog.

Organize the tour

5. Tweak the map extent (Extent tab)

6. Enter a subtitle

Use the first point as introduction
(does not appear in carousel)

Reset order and hidden points

7. Change the Basemap. Choose Imagery With Labels (if you
Apply Cancel Iike)

© Esri 2016 Page 5



StoryMap Training: Map Tour @esri

Then save your tour. You can share it with your intended audience. Click the Share button at the top
of the Story Map Tour Builder.

Optionally, you can add additional data into the web map used in your Map Tour. In this case, the
route of the hike is available as feature layer created by uploading GPS trace data into ArcGIS
Online and making a feature service.

Edit the web map used in your map tour to add this additional layer. You can do this in ArcGIS
Online or via the My Stories section of the Story Maps website. In My Stories, find your story,
expand it to see its contents, click the Maps tab, and click Edit Map.

[ CREATE STORY

& 4

Search your stories... Sort v Filter v / > L a— o Ed CHECK STORIES
. T =———— 4

A Winter Hike in Mammoth —
Map Tour | Private | Modified June 24, 2016 | 0 views 24
Summary style .
No summary, click to add one. three-panel —
Shared: Private basemap g
(2 B3 / EDIT STORY [ PREVIEW Topographic

[
|
Noissues found ¥ Status Name Shared
(V) A Winter Hike in Mammoth g e <)
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In the web map, click Add > Search for Layers, set 'In' to ArcGIS Online, and search for 'winter hike in
mammoth route’. This is the feature service of the route:

Alternatively, if you wish, you can download that shapefile as a zip file from:
http://downloads.esri.com/blogs/places/training/mammoth route.zip

Home * A Winter Hike in Mammoth

Then upload it into your web map using Add > Add Layer From
File. For example if you are using a free ArcGIS Public Account Details| 88 asemap | [EJ Anslysis
instead of an ArcGIS Subscription (and therefore can't publish
your own feature services), you can still upload file-based data
into a web map. GPX files from a GPS-enabled device can also IT“ Lr';;f; :tﬁr: mammoth route
be uploaded directly into a web map as line features, as can R

CSV files representing point features). 1 Result Found

Mammoth Winter Hike route
8 by Rupert_Essinger Rdd

Search for Layers

Symbolize the route layer in the web map.

You are using the Imagery with Labels basemap, which by
default doesn't show roads and street name labels.

However you can easily add those in by adding the 'World Transportation' layer from ArcGIS Online
to your map. Choose Add > Search For Layers and search that layer in ArcGIS Online:
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[£] Details BE pasemap | [ Analysis Save the map.

Search for Layers

You are done!

— P— - You'll see the updated map appear when you view your map
LR Tound ' tour. After adding additional content to your map, you don't
lorld Transportation - . . .
Add need to open your tour in the Map Tour Builder again: those
World Topographic Map changes will appear automatically because the tour simply

E3 by esri Add

. displays that map.
Note: when you edit a web map that is used in a map tour, be careful not to delete the layer you'll
see in that web map called 'Map Tour layer': that's the layer that the Map Tour Builder creates and
manages in your web map to store the points in your tour.
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Optional: Make another Story Map Tour using Flickr photos that don't have
locations stored with them

If you want to try a different set of photos from Flickr, including some that don't have locations
stored in Flickr, enter the 'Rupert Essinger' account name and choose the album called ‘A Hike Along
Offa's Dyke in Wales'. This set of photos will also introduce you to an interesting and historic part of
the United Kingdom!

Flickr import

Enter your Flickr user name and select a Photo Set or a Tag to be
imported. Your pictures must be shared publicly. The import will be
limited to the first 99 pictures.

Rupert Essinger Look up

A hike along Offas Dyke in W r
San Diego (26)

San Diego Design (7)

San Diego Fun (9)
San Diego Food (10)

Please Choose

Select a Photo Set or Select a Tag

|| Anike along Offas Dyke in Wales (23) i

When you import that set of photos, you'll be able to specify the locations for those photos that
don't have locations stored in Flickr.
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Optional Advanced Workflow: Make a Story Map Tour using existing point
dataset

This workflow demonstrates an advanced workflow that enables you to use existing point data to
define a Story Map Tour. This is useful if you have existing GIS features or spreadsheets of places
that you want to use in a map tour. Your existing data can be used to define a map tour. This
workflow enables you to automate the creation of map tours and build them from existing datasets.

Welcome to the Map Tour Builder In the Story Map Tour Builder, you can download a data
template as a spreadsheet. This template shows you the set
of fields that the Story Map Tour uses for point locations.

Where are your images or videos?

They are already online I need to upload my images You'll find this under the Advanced Options:
r“
o E © ,
You | Advanced options
m E

Learn mare Start a new Tour

Import Tour data from a CSV file

Download the CSV template

Make a selection Back
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Any point data layer that contains those fields can be added to a web map, and then you can share
that web map in ArcGIS Online and create an app from it, choosing the Story Map Tour as the app
that you use to publish your map. For example if you have existing GIS point data that you want to
use in a Story Map Tour, you can add the expected set of fields to that data and use it to power a
map tour. Pictures are referenced directly via URLs. Lat and Long fields don't need to be added if
your point data is already a point layer, such as point shapefile layer or feature service.

This same workflow also enables you to define the content of a map tour entirely in an Excel
spreadsheet and then import that spreadsheet into the Story Map Tour Builder. This is the workflow
that we used to create the San Diego Places To Eat Map Tour.

You can find that map tour on the "Soak Up San Diego" web page which contains a set of story
maps about the User Conference and San Diego: http://www.esri.com/events/user-
conference/activities/soakup-sandiego

This map tour makes use of HTML tags in the captions to format the text:
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o

Puesto New wave Mexican restaurant in the upscale new Headquarters, an
adaptive re-use of a historic police station. Lively, interesting space with
large patio. Tuesday evening deals on tacos & drinks are popular with
locals. There's a small museum opposite where you can go into one of B2 -7, / @,‘
the building’s original cell blocks. S s

Neighborhood: Marina District
789 West Harbor Drive in The Headquarters

SanGlS, B

The Lion's Share The Fish Market Cafe 222 The Field Searsucker Vin De Syrah Spirit & Wine Tajima Ramen, East Vi
Parlor

In the Story Map Tour Builder you can enter HTML tags directly into the captions as you edit them.
However for more complex HTML tag formatting, like we use in the Places To Eat tour, you may
want to automate how the caption text is defined, in order to avoid having to enter lots of HTML
formatting manually. Using an Excel spreadsheet you can use the ability to concatenate text from
different fields together in order to automatically generate the Description field. In this part of the
tutorial you'll import a ready made spreadsheet to see the end result of this.
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Assuming you have Excel on your machine, open this spreadsheet and save it locally to see the file
we used to define the 'Places To Eat in San Diego' map tour:

http://downloads.esri.com/blogs/places/training/locations.xlsx

After saving this file, open it in Excel then export it to a CSV file using File > Save As.

If you don't have Excel on your machine you can open the CSV (Comma Separated/Delimited file)
that we created by exporting the spreadsheet from Excel. Save this file locally:

http://downloads.esri.com/blogs/places/training/locations.csv
(filename is locations.csv)

Advanced options

Start the Story Map Tour Builder again.
Choose the Advanced options dialog, and in
Start a new Tour that dialog, import the CSV file to create

your tour. You can now continue to edit this

map tour, save it, etc.
Download the CSV template

(Use right click and "Save as" if download doesn't start)
1 .
That's it.

Make a selection Back

Thanks for trying out the Story Map Tour.
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